1

I have installed Drupal. I followed a tutorial in Lynda.com that uses Acquia Dev Desktop, and then the core Drupal inside. (http://www.lynda.com/tutorials/73655-2.html)

I'm not sure if it is the best way to install Drupal. Anyway, it works. But now I need to access to the web from another laptop that is in another room. I can't.

When I see the web in the original mac, I have: http://nameofproject:8082/

From a second mac, to access to the Drupal web installed, I tried and it doesn't work:

  • http://IPnumber:8082/(This drives me to the generic Acquia Drupal site)

  • http://IPnumber:8082/nameofproject

  • http://IPnumber/nameofproject:8082/

  • http://IPnumber/nameofproject/

3
  • You can't access the site with just IPnumber:8082? Also make sure that your router's port forwarding settings are set to allow that port open. Jul 11, 2012 at 14:44
  • With iPnumber:8082 in the guess mac I go to the same place that I go when I write localhost:8082 in the mac that has the Drupal. This is a generic Acquia Drupal wellcome site. So I suppose the router allow that port? What I need is to acces to the Drupal site inside.
    – Narcís
    Jul 11, 2012 at 15:15
  • Ok if your getting the Acquia page then your router settings are fine. Try IPnumber:8082/nameWeb Jul 11, 2012 at 15:20

2 Answers 2

1

If you have a web server installed on your local network, and you type the IP address in the URL (e.g. IPaddress:port/nameofproject), you should get your Drupal site.
The fact that when you just type the IP, and the port you get the default server page means that your router settings are already working.

9
  • With this: IPaddress:port/nameofproject all the browsers say: "can't connect to the server" In the mac that I have the Acquia Dev Desktop with the Drupal inside I can access to different Drupal webs with nameofproject:8082
    – Narcís
    Jul 11, 2012 at 15:54
  • Try without the port. IP/nameofproject. It will need to be one of the variations of that. The reason I say this, If you can get to the default page. Your just typing the url incorrectly. Jul 11, 2012 at 15:56
  • I tried and doesn't work: iP/nameofproject I think I tried all the combinations possible and with different projects. What you say makes sense but it doesn't work, I don't know why. Perhaps there is something that I don't do wright
    – Narcís
    Jul 11, 2012 at 16:05
  • On the default page. Does it say anything like; Projects? where you can see the current project your working on? Jul 11, 2012 at 16:07
  • 1
    I use mamp on my work dev server and it works without any problems. Jul 11, 2012 at 17:03
0

I got it to work by adding to the host file.

My mac has Acquia Dev Desktop installed. I'm trying to access the site "example:8082" on a Windows 7 virtual machine.

I go to the virtual machine and edit the host file like this: 10.10.17.111 example

Then to access this from the Windows 7 browser, go to "http://example:8082"

Bingo, it works!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.