0

So I've installed a new Drupal 7 on my server, and installed the "AntiSpam" module with Drush. ([See Installing modules without FTP.)

I can't configure the module. When I open up the Configuration panel, I get an error message, saying:

Akismet spam protection service requires a...

When I click on "Configure," I get dropped back to the Configure menu.

What did I miss? Drush didn't display any error message, and the module shows up in the modules page as enabled.

2

The module asks for an API key, as the description for the "Akismet API key" field on admin/config/antispam says:

Please, enter here your Akismet API key. If you don't have one already, you can get it by simply signing up for a free account at Akismet.com. Note that this information is required in order to use the Akismet Service. Please, consult the Akismet FAQ for further information.

Drush doesn't report any error because there isn't any error to report. Only after you enable the module you can see its settings page, where you need to enter the API key. Even if you installed the module using the browser, you should not have seen any message about entering the API key.

If you cannot access the setting page to set the API key, you can:

  • Obtain the API key using the link I reported before
  • Use Drush to set the Drupal variable antispam_wpapikey

    drush vset antispam_wpapikey $key
    

(Replace $key with the API key.)

  • The problem is that I cannot go to the Configure page. When I click on the link, it drops me back to the "Configuration" menu where it shows the error. It's an endless loop. Like the module got installed in a bad way or I don't know. :/ – Apache Jul 14 '12 at 15:47
  • I don't know why you get redirected; I installed the module, and I didn't have any issue. I added a workaround to set the API key requested from the module. If you still have the same issue, then I would uninstall, and re-install the module, and check there aren't modules that create problems. – kiamlaluno Jul 14 '12 at 16:43
  • That worked, setting the API key that is. But I still can't configure the module. It drops me back all the time. – Apache Jul 14 '12 at 16:56
  • Gotcha! You can install modules, but you have to enable them via the Drupal admin menu. Unless you do this, the modules won't get enabled properly. – Apache Jul 14 '12 at 17:00
  • Flush your cache too. I was having trouble till I did this. – dibs Feb 13 '13 at 21:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.