After successfully migrating from Drupal 6 to Drupal 7, I wanted to migrate my CCK fields to core fields. I downloaded CCK for Drupal 7, and its field migrate module.

However, for all of my image fields, I got this error:

Missing field module: 'image'. This field cannot be migrated.

What is that module 'image' that is missing? There is no more imagefield for Drupal 7, as it is supposed to be part of core.

  • Does the image module actually exist? Have you tried manually enabling it? The files should be in [web-root]/modules/image/
    – Letharion
    Jul 15, 2012 at 11:18

1 Answer 1


Actually, the Image module is part of Drupal core. Enable it, and the error should vanish.


If you don't find the module listed between the modules, then you need to copy the Drupal files again on your server.

If the Image file is already present in your web server, it is enabled, and CCK keeps saying it cannot find the module, then open an issue report for CCK.

  • 1
    You are right! I love you! By the way, this should be clarified in the translations. If it said "disabled" and not "missing", I would have found straight away.
    – gkpo
    Jul 15, 2012 at 13:12
  • The message could say the module is disabled, or missing. At least, users would check first if they need to enable it, and they will notice if the module is not present. Considering the module is part of Drupal, maybe the message error should also give more information. The function used in these cases is module_exists() which (despite the name) checks the module is enabled; if the module is not enabled, the function returns FALSE.
    – apaderno
    Jul 15, 2012 at 13:25
  • A little necro I know, but this doesn't work for me. The D7 Core 'Image' module is enabled but the Content Migrate page (/admin/structure/content_migrate) is still reporting that Missing widget: The 'image' widget is not available for the field_background_image field, it will be set to the default widget. I've cleared cache and all, still coming up as an issue - anyone got any thoughts?
    – nbsp
    Mar 18, 2015 at 3:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.