7

I am using Media and Wysiwyg with CKEditor to insert images in the post editing field, and for some reasons I keep getting this code instead of my images.

Does anyone know how to fix it?

[[
  {
   "type" : "media",
    "view_mode" : "media_large",
    "fid" : "412",
    "attributes" : {
      "alt" : "",
      "class" : "media-image",
      "typeof" : "foaf:Image"
    }
  }
]]

[[
  {
    "type" : "media",
    "view_mode" : "media_large",
    "fid" : "395",
    "attributes" : {
      "alt" : "",
      "class" : "media-image",
      "typeof" : "foaf:Image"
    }
  }
]]

I fixed it; you have to go into Administration » Configuration » Content authoring » Text formats and check the box Converts Media tags to Markup.

9

I fixed it; you have to go into Administration » Configuration » Content authoring » Text formats and check the box Converts Media tags to Markup.

  • 1
    This is what should be in Drupal instead of that error message – Alex K Jun 4 '13 at 11:27
  • This isn't solving the problem for me. – Randell Nov 27 '13 at 10:47
  • I have the same problem and checked the "Convert Media tags to markup" option, but the image (in my case) is not shown (I have the problem when creating a tcpdf file). – schulle877 Sep 8 '14 at 6:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.