4

I have an unlimited items on a simple filefield using an image widget. When a user upload more than 95 images, after saving the node, it turns it to unpublished and it removes the authoring information.

Afterwards, when you go back to edit the node it doesn't save any changes. Basically you have to go to the database and delete the extra rows until there are only 95 to be able to edit the node again.

This is critical because most of the nodes are supposed to have around 130 images.

Any suggestions?

I've already increased the php memory to 128M thinking it might be a memory problem because it looks like the save function is not executed properly.

Also, worth noting that if I change the order of the field on "manage fields" and get the image field on to the last slot, it save everything but the image field.

Thanks in advance! Any help will be greatly appreciated!

Installation:
Drupal 6
CCK - 6.x-3.0-alpha3
FileField - 6.x-3.10
ImageField - 6.x-3.10

3

Solution is to increase upload_max_filesize and post_max_size in your php.ini. Because POST data can be truncated if it exceed specified limits. This can happen when you upload lot of images and send them all in one big POST.

Other way to fix this - is automatically upload image via AJAX request just after user select it - try JavaScript code from How can I automatically upload images on file selection rather than pressing the upload button?

Also try to increase max_execution_time in PHP settings. PHP may be lack of time to upload and save all 95 images during default 30 seconds.

  • Thank you! I'll try that! Do upload_max_filesize, post_max_size and max_execution_time can also be changed in .htaccess? – Pedro Gonçalves Jul 17 '12 at 16:35
  • php_value memory_limit 128M, php_value upload_max_filesize 128M, php_value post_max_size 128M,php_value max_execution_time 30000 on .htaccess didn't work. ------ But I've tried install the same exact site on a bluehost server and it worked so I guess the problem is the server. ------- The final and problematic installation is on MediaTemple – Pedro Gonçalves Jul 17 '12 at 18:06
  • PHP directives could to work only in php.ini but not in .htaccess - it depends on server configuration. – Eugene Fidelin Jul 18 '12 at 12:36
  • I checked through phpinfo() and it looks like it worked. – Pedro Gonçalves Jul 18 '12 at 23:07
  • If you have post_max_size=128M and tried to upload 95 images, then every image must be smaller than 128/95 = 1,3MB. Maybe your images are bigger? – Eugene Fidelin Jul 20 '12 at 17:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.