0

I am trying to transfer a site over, and run update.php.

Drupal is telling me that my system and menus modules are out of date. This is not the case - they're both up-to-date, in fact I downloaded the most recent ones and uploaded them to my public_html/sitename/modules folder.

Where is the version number stored, so that I can force Drupal to recognize that they are the correct module versions that Drupal is looking for?

Specifically for the menu and system modules.

This is in D7.

  • 1
    The module's .info file will have the version number...what does that say? – Clive Jul 18 '12 at 13:09
  • name = System description = Handles general site configuration for administrators. package = Core version = VERSION core = 7.x files[] = system.archiver.inc files[] = system.mail.inc files[] = system.queue.inc files[] = system.tar.inc files[] = system.updater.inc files[] = system.test required = TRUE configure = admin/config/system ; Information added by drupal.org packaging script on 2012-05-02 version = "7.14" project = "drupal" datestamp = "1335997555" – Jack Ryan Jul 18 '12 at 13:15
  • That's for the system module. – Jack Ryan Jul 18 '12 at 13:15
  • Yet I still have this: Error Unresolved dependency System (Version >7.10 required) Administration menu requires this module and version. Currently using System version 7.4 Error Unresolved dependency System (Version >7.10 required) Administration menu Toolbar style requires this module and version. Currently using System version 7.4 – Jack Ryan Jul 18 '12 at 13:15
  • 3
    are the older versions still there in renamed directories? if so that might explain what's going on, eg, drupal is seeing the older version in old_system/system.info instead of system/system.info – Jimajamma Jul 18 '12 at 13:22
4

As Jimajamma in comment #2 pointed out it is worth to check whether there are older versions in renamed directories.

I had the same problem and error message with modules - after removing the backup below "sites/all/modules/old" the dependency check error in update.php was gone.

0

Not sure if it's related, but I had upgraded from drupal 7.27 to 7.31 and had an issue running update.php. So u ran drush updb instead.

I still ran into problems with the version being listed as 7.27 when checking it with "drush status". Turns out in the drupal root includes/bootstrap.inc there was a file that didn't cp over correctly. In which sets variables that set the version in the app itself and for the drush command.

I also verified that the database had the correct information in the systems table. Which was showing 7.31. : )

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.