1

i've started using Drupal few days ago and from the start i've noticed very slow page load, right after installation, i though it's normal and forgot for a while about this problem.

I am running Apache 2.2 and PHP 5.3 on local PC (Core2Duo 2.4, 3GB Ram) with Drupal 7.14.
I have tried using shared hosting (5% of some Xeon CPU, 256Mb Ram for PHP) - same problem, pages took ages to load, not to mention Admin pages loading for 3-5sec, sometimes - minutes. Sometimes UI and Pages are very good, sometimes it hangs for few seconds, minutes even. Always using Ctrl+R for page reload to skip caching on browser side.
Today I've installed Performance module and did the test on shared host with a little content on page and on blank installation of Drupal at local machine mentioned above.

Results on Local: http://s14.postimage.org/ij1isbh33/Drupal_7_Local_default.jpg
Results on Shared: http://s11.postimage.org/asjhasu29/Drupal_7_shared_content.jpg

On local - first time its default installation, second time logging disabled, caching everything, aggregation etc. Therese a phpBB3 default running on shared and local - very responsive, no hangs, page loads in a few ms.
Also, the amount of Queries, is this normal for Drupal to have 30-200 Queries?
What could be the problem with this issue?

  • 1
  • I've recently experienced a similar slowdown, as never before, and I could talk my host rep into installing drupal.org/project/memcache. After installing and configuring memcache in Drupal, the improvement was instant. – Artur Jul 19 '12 at 20:01
  • I have just tried Memcached with Drupal module, no performance boost on loading index page as seen on screenshot: s9.postimage.org/xz0kaxo71/Drupal7_local_memcached.jpg – BShip Jul 19 '12 at 21:30
  • Also, local site is fresh install, with default modules and Performance module installed. Issue with missing modules from installation doesn't apply :( Tried with Cron enabled/disabled - same results. – BShip Jul 19 '12 at 21:50
2

Things to try:
http://groups.drupal.org/node/242443
http://groups.drupal.org/node/210683

But in reality we don't know until you can profile the code.
http://getmuhammad.blogspot.com/2011/08/installing-xdebug-and-webgrind-on.html

  • Thanks, will install xdebug and webgrind today on local and post results. But cant install on shared hosting, don't have rights to do so :( The major problem is random hang up, for example sometimes page takes 3-10sec to load, even after 2-3-5 refreshes and sometime page opens fast (500ms). As for now, 500ms for content-free website is horrible :( – BShip Jul 20 '12 at 7:29
  • Theres a link to that site on shared hosting: itship.ws/demo/site1/v1 – BShip Jul 20 '12 at 7:31
  • Just looking at your site it firebug I would blame your hosting. It took me 4.9 seconds to get a 304 response back. Doing a forced refresh took 1.5 seconds and that was a cache hit according to the http headers. My recommendation is to get better hosting... at least from what I've seen here. More info: webpagetest.org/result/120720_NR_NW2 – mikeytown2 Jul 20 '12 at 17:14
0

This is a known problem with MediaTemple's Grid Servers and supposedly doesn't happen with their "1 click installs" of Drupal. The issue is that Drupal's database queries are very very heavy, and their shared MySQL instance is underpowered.

Apparently the fix is to change the table type from INNODB to MyISAM for any tables who's name starts with "cache" or "variable".

0

Check your log, if the admin pages are taking awhile to load then it's likely a memory leak in one of the modules that are enabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.