6

I have a vocabulary that I want to shows as menu. For this, I installed the taxonomy menu module and edit the vocabulary to hang from a menu item of Main Menu. The menu is shown perfectly.

The problem goes when I localize the terms of vocabulary, the menu is only shown in a default language. I have tried to rebuild the menu (by checking the "Select to rebuild the menu on submit." on vocabulary edit page and submitting), but the problem persists.

  • did you find a solution for the problem? – headkit Aug 11 '12 at 10:52
  • 1
    Taxonomy menu has no i18n integration. See drupal.org/node/1798700. So a solution for this problem passes by writing such an integration, or perhaps some custom code. – jonhattan May 16 '13 at 8:23
2

Entity translation

Allows (fieldable) entities to be translated into different languages, by introducing entity/field translation for the new translatable fields capability in Drupal 7. Maintained by the Drupal core i18n team.

together with Title module - (making the taxonmy terms translatable)

Title module

After enabling the module as usual, visit the Manage fields page of the content type, taxonomy vocabulary or "comment type" which you wish to replace fields of and click the replace link. That's all.

| improve this answer | |
1

You can: 1) Install Entity translation and enable taxonomy term in TRANSLATABLE ENTITY TYPES (admin/config/regional/entity_translation).

2) Install Title and (admin/structure/taxonomy/YOUR_VOCABULARY/fields) make "replace" title with title field.

3) Enable "Translate and Localize" option in your menu settings.

4) Install Taxonomy menu dev release.

5) Apply patch drupal.org/node/1665308.

6) Rebuild your taxonomy menu.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.