2

I have setup the ldap module for Drupal 7 - everything is working as it should, apart from when a user logs into the site the role defined for that person isn't been assigned to their profile, they remain just an authenticated user.

When I run a test on their username it shows that the user should be part of the correct role.

In the error log I can see it is failing when granting a single authorisation with the following error:

LdapAuthorizationConsumerDrupalRole.grantSingleAuthorization() failed to grant xxx the role Delegate because role does not exist

However the Delegate role is setup and present.

Has anyone else come across this problem?

--

Just to note that I found the solution - don't use capitals in your roles. Changing Delegate to delegate fixed it. I will put this as the answer when my 8 hour self answer delay lapses.

1

Ok so I found the solution - which made me kick myself :p

In order to get the role mapping working the role names have to start with a lower case letter - so in my example I changed the role name from Delegate to delegate and it is all working now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.