I had a site in Windows installed inside xampp. I copied the same site's folder and database from windows-xampp installation to Ubuntu's www folder (Lamp) . The menu links are not working now. localhost/sitename directs to the homepage . But when I click on any menu items , it says

The requested URL /sitename/latest/11 was not found on this server.

I could not figure out if this is problem of localhost or menu or database?

I can't even login because users/login is also not working.

Any suggestion or any links to the articles that I should read to solve this problem would be great. Thank you .

  • Have you tried user/login to login? (note user not users)
    – Clive
    Jul 23, 2012 at 14:33
  • Yes I did but does not work.Gives the same error. Jul 23, 2012 at 14:34
  • Sounds like .htaccess did not copy over with the rest of the files. Check to see if that file is present in the site's root folder.
    – sheena_d
    Jul 23, 2012 at 14:35
  • I checked for .htaccess file . It is present there . Jul 23, 2012 at 14:37
  • Are you using the same database name in ubuntu..all credentials stuff?
    – Minty
    Jul 23, 2012 at 15:01

1 Answer 1


My suspicion is that Drupal's .htaccess URL rewrite directives have been disallowed in your Ubuntu installation of Apache. If it were a bootstrap or database connection problem, you would not be able to see the front page either.

Ordinarily, Drupal prevents Clean URLs from being activated if not supported by the server. In this scenario, of course, that test was done in the Windows installation. Ensuring rewriting support in the target server is at the top of the migration checklist.

The quickest way to see if Clean URLs is the culprit is to try browsing to localhost/sitename/index.php?q=user/login ; if that page does come up, you will need to enable rewriting in your web server.

See http://drupal.org/node/1186762#comment-5424052 for some instructions on checking your Apache configuration to make sure it allows Drupal to rewrite URLs in its .htaccess file.

If you can confirm that the .htaccess file is being read, rewrite directives have been allowed in Drupal's installation directory, and that mod_rewrite is active, and still see problems, I would check next for a corrupted menu table.

  • Yes the problem was Apache's rewrite problem. sudo a2enmode rewrite worked for me . Thanks a lot for the help. Jul 23, 2012 at 15:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.