2

I am trying to figure out how to use this module.

I've downloaded it, installed it, etc. However, when I try to set up a webform, I'm not seeing anywhere where I can upload files and redirect to a link programmatically.

Where do I set this up?

I found this online, but I don't see "protected" anywhere.

Configurations on my site:

  1. Installed the modules (Webform Protected Downloads, Private Upload)

  2. Changed 'Default Upload Privacy Setting:' to 'Public' under 'admin/settings/private_upload'

  3. Created a Webform > attached a file

  4. Under 'File attachments' selected 'Public'

  5. Enabled 'Protected' under 'Protected Downloads'.

  6. Enabled 'view uploaded files' permission for anonymous users under 'admin/user/permissions'

  • 2
    Have you added a File field to your webform to allow users to upload files? This module will not do that; it only adds enhancements to webforms that already allow uploads. – EmmyS Jul 25 '12 at 16:29
  • A file field is supported, yes, but I don't see any "protected" section, only a private section. Nor do I see where it is supposed to link the user/redirect. – Jack Ryan Jul 25 '12 at 16:52
2

The D6 version of the module doesn't support filefield. You must use the drupal upload module. On the node edit form: Attach a file, set it to private. Switch to the tab "Protected downloads" and specify your settings there. If you don't see the tab "Protected downloads" then it might be a bug. Consider opening an issue for this on the issue queue for the module on drupal.org.

  • Your're welcome. Small addition for other users that might find this question: Remember to grant the permission "administer webform protected downloads", otherwise the tab "Protected downloads" is not available. – berliner Aug 9 '12 at 18:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.