3

Possible Duplicate:
Performance Problem: Delay on first request

The first page of my site takes up to 15 secs to load and then the site become responsive. If I leave the site for 20 min or so, the first request is very long again.

Following recommendations found on this similar question, I checked the Devel query logs and there is a whole bunch of queries related to field_sql_storage_field_storage_load taking more than 250ms. I am not sure it is purely related to field_sql_storage_field_storage_load though as there is another language_list query with a simple SELECT * FROM languages ORDER BY weight ASC, name ASC taking 186ms.

My questions are: why do I encounter such delays and how can I reduce them?

  • 3
    I've started a bounty on the other question, hopefully that'll get this issue some attention; it would be nice to get a good answer for it – Clive Aug 2 '12 at 19:33
  • Just an idea, have you try your site configuration in another server? At the end it might be MySQL or DB configuration error. Also if the DB is on a separated server check for connectivity and firewall issues. – Emil Orol Aug 3 '12 at 4:20
  • @NathanZ can you tell whats the result of this select count(*) from node where promote = 1 – GoodSp33d Aug 3 '12 at 6:08
1

So this is how I fixed the problem. It is not a real solution as I could not nail the exact source of the problem (if there is one).

1) Aggregate CSS (cache settings). This reduced the latency by half 2) Set cron to never (and run it externally) 3) Set up a cron job that calls the home page with Lynx every 30 minutes

Not the answer you're looking for? Browse other questions tagged or ask your own question.