3

I have followed this tutorial exactly http://drupal.org/node/1002852 to create a node type with geocoding. I have a default install of openlayers, openlayers_geocoder. Geocoding appears to be working when editing/saving the node, however the marker (or polygons) do not appear on the node's map.

  • Did you try using Open Street Map instead of Google Maps and if it uses v2 API of Google Maps it will require an API key. – Adam S May 20 '11 at 4:59
  • yes. I am using open street map. (using everything that comes default after installing the modules). Since I haven't set anything, I am thinking there must be a setting i am missing. I have gone through everything. – user842 May 24 '11 at 15:06
  • Am I missing something? Question is tagged 7 but there is no Drupal 7 release for openlayers_geocoder. Are you in fact using Drupal 7? – Laxman13 May 26 '11 at 17:05
  • I believe he meant drupal.org/project/geocode, which has a Github repository with a drupal 7 version. Or maybe even drupal.org/project/geofield, which has to be used too, if one is going to use geocode. – Fidelix May 26 '11 at 17:45
  • somehow this got retagged with Drupal 7. It is fact Drupal 6 that I am having issues with. – user842 May 26 '11 at 17:48
4

I have gone through this same problem.

I believe this is happening to you, because you did not set the Openlayers Data Overlay on Views.

Data Overlay

And if you did, you did not selected/activated it on your Openlayers preset:

Openlayers PRESET

And if you did, you did not map the fields on the openlayers data overlay display settings:

Format settings

| improve this answer | |
  • The issue is not with the views, but rather the map on the node itself. – user842 May 26 '11 at 17:49
  • Yes, but in order to display the map on the node, you have to set an Openlayers Data Overlay within Views. This is mandatory. – Fidelix May 26 '11 at 18:38
  • with d6, there aren't any default views to modify? – user842 May 27 '11 at 3:42
  • Not that I know of. You have to build everything for yourself. Try following EVERYTHING here: drupal.org/node/627816 – Fidelix Jun 1 '11 at 14:06
0

I ran into this problem as well, but in my case it was that I didn't have the proj4JS library downloaded. I ran drush dl-proj4js, cleared caches, and all worked as expected.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy