2

I use Field collection modules to group image + textarea for multiple field group inputs. When I click "Add another item" button, ckeditor bar disappeared from the textarea.

I think there would be some errors occured on Ajax request for an iframe tag appeared at the bottom of the script.

This thing only happened when field collection group contains both image and textarea. Field collection with only textarea are fine.

The modules I use:
wysiwyg 7.x-2.1
ckEditor 3.6.4.7575
IMCE 7.x-1.5
File Field Sources 7.x-1.4
field collection 7.x-1.0-beta4

1

I had this problem as well. This was fixed in http://drupal.org/node/1155678#comment-5358290 by adding a detach function to the WYSIWYG behaviors. You can apply the patch at the above link (that's what I did) or you should be able to download the 7.x-2.x-dev version (I haven't tested that) since it's been committed already.

  • Yes, I see wysiwyg.detach.13.patch but I don't know how to add it to WYSIWYG behaviours. I'm a newbie to Drupal. Could you kindly provide me with the detail instruction? Thanks for your help. – Pyone Kay Khine Aug 31 '12 at 11:24
  • 1
    I would recommend just installing the 7.x-2.x-dev version of the module as it includes some other useful patches. You can also apply just the patch to fix this issue by following the instructions at drupal.org/patch/apply – rocketeerbkw Aug 31 '12 at 17:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.