I migrated a site from windows xampp to ubuntu. It was working fine. But once I cleared the cache, the browser is showing blank screen.I tried going to different urls . I also tried clean urls but nothing is coming. All I can see is a white/blank browser.

  • i guess your ubuntu is a local environment without any access limitations, additionally suggest that you check the php error log for any quick hints of code level errors (ensuring that error reporting is on and set to a preferred level...) – optimusprime619 Aug 6 '12 at 9:38
  • 1
    check the logs, they usually point to the problem, on ubuntu check your apache and syslogs. – karthik Aug 6 '12 at 12:48

The White Screen of Death (Completely Blank Page) is a good starting point to takle down the problem.

For D7, extension=php_domxml.dll in php.ini must be commented out. With that dll enabled, I got a blank screen too in Windows.
Check with your php configuration in your linux server.

  • the given link worked for me . I just had to make some changes in index.php. I added this in index.php. <?php error_reporting(E_ALL); ini_set('display_errors', TRUE); ini_set('display_startup_errors', TRUE); – Sandesh Yadav Aug 7 '12 at 5:53
  • What did you see the error on your screen after you enabled error reporting? – Sithu Aug 7 '12 at 6:02
  • The error was regarding a module that I was not even using anymore. So I deleted that module and everything worked fine. – Sandesh Yadav Aug 7 '12 at 6:30
  • Then, you may need to retag because I think the tag "caching" is not directly related with this subject. – Sithu Aug 7 '12 at 6:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.