7

I have installed i18n, changed settings.php according to this guide, set language detection to url and cleared cache.

Then on site config page, I set the url prefix to English and all UI changed to English. Then I updated the Site Name to something English.

Then I repeated the above steps for a local language.

But it looks like changing the url path prefix each time gives me identical results regarding Site Name, i.e. the Site Name is changing each time I update it, no matter which language path is chosen.

What am I doing wrong?

P.S. In table "variable" the site_name is just one. I never used i18n before, no idea how it should look here.

9

To translate a Drupal 7 Site name you have to activate Variable translation module (which is in the same package as i18n) and the required ones (like Variable store).

After you install these modules, go to Configuration -> Multilingual settings -> Variables tab and choose Site name (?q=admin/config/regional/i18n/variable),Then go to Configuration -> System -> Site information (q=admin/config/system/site-information) and select the language you want. Change the Site name field and save.

You'll find the translated site name in variable_store table.

| improve this answer | |
  • I have done exactly like you explained but on site information variable does not appear please suggest ? – jas Feb 18 '16 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.