5

I have an image field that allows a single image to be uploaded. The selection works, but if I click upload, I get an AJAX error. If I just submit without uploading first, the image is uploaded properly. If I go in to edit that image field and click remove, I again get an ajax error.

An error occurred while attempting to process /file/ajax/field_front_image/und/0/form-XprUtXJvTcMRlmsz3CmBs6uDFpuJcev4SO_I_PvsM-E: Array.prototype.reverse called on null or undefined

I get this error locally and on the production server. It happens for all image fields and it's the same error when clicking upload or remove.

How can I fix the ajax on these form fields?

2
  • What kind of Image modules do you have installed? – Johnathan Elmore Aug 9 '12 at 16:58
  • just the core image module – gregghz Aug 9 '12 at 19:26
6
+50

Please check your theme's jQuery and Drupal jQuery conflicts. Check 'View source' and check the jQuery version the page using.

I had similar issue when used latest jQuery in my theme.

3
  • So I have some mootools code being loaded as well. It's not the entirety of mootools, but I'm beginning to suspect that it may be conflicting somehow. I'm going to disable some javascript and see what I come up with. – gregghz Aug 13 '12 at 16:50
  • is any custom code involved or are you working solely with core and drupal modules/themes? is it possible that someone forgot to wrap custom jquery (drupal.org/node/772500)? – doub1ejack Aug 15 '12 at 20:52
  • solved the problem on by installing jQuery Update module and setting the JQuery version to 1.8 – John81 Mar 15 '13 at 17:54
0

We had this problem in 2 month ago. this problem issues form server and not depended to drupal core.we try to solve this problem, and test any ideas(clean drupal cache, recreate fields, change permission of file directories )but all of them not work. Just I can suggest you put you contentrate in server and cache layer of server( nginx cache, varnish cache if you have )

maybe be useful using clearstatecache and commands like this.

Certaintly problem is in server not in drupal

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.