enter image description here

All other pages are being loaded fine but when I go to permissions page it comes like this. What may be the reason for this ? Please help.

  • I tried in different browsers and also cleared the cache. Still getting the page like that. Aug 10, 2012 at 7:38

4 Answers 4


I had exactly the same problem few days ago. Do you have the devel module install?

For me it was the problem, i can't explain why but when i desintalled it, all worked fine.

So maybe, try to desactivate and unistall it and maybe your page permission will work again.

PS: i just re-install the devel module to make a test and i have exatly the same permission page than you. For me it's the devel module the problem. (I'm new in Drupal so i had certainly make a mistake somewhere)

  • Oh you are right. Uninstalling devel module solved the problem for now :). But we should also look for the permanent solution. Aug 10, 2012 at 8:15

This could probably be a PHP Memory Limit issue. Is this only happening on your local / dev or also on your remote server?

  • I have not uploaded to remote server yet.Still developing. If PHP memory is issue , how to solve it ? Aug 10, 2012 at 8:02
  • Run a phpinfo() (or use the devel module /devel/phpinfo) to see how much memory you have. Its the memory_limit value. TO increase, you need to set another value in the php.ini or ask your hoster.
    – Lance
    Aug 10, 2012 at 8:05
  • @Lance- I increased the memory limit from 128 to 256 in /etc/php5/apache2/php.ini . But still showing the problem when I install devel module. Any other reasons for this problem that you know ? Is the php.ini file that I edited was correct or I should get the file somewhere else ? I need to solve the problem permanently. Thank you. Aug 10, 2012 at 8:29

I have the exact problem noted above, but after checking my modules, I do not have devel installed. Are there any other solutions to this issue out there?


May be the permission listing makes the memory problem.You have to update the permission listing page to a simple one.

Try the Filter permissions module

  • How would this module help, exactly?
    – Mołot
    Sep 1, 2015 at 15:05
  • There may be lots of user roles within the app. While loading all the permission together may cause the page break.. Sep 2, 2015 at 5:22
  • This module will let you select each role with many types. All to All is also possible too Sep 2, 2015 at 5:23
  • Please edit your answer to provide details. Comments are for more "side" tasks, like asking for claifications ot notifying they were made.
    – Mołot
    Sep 2, 2015 at 6:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.