1

I´ve read many posts about this problem, and tried many things, before deciding to open this one. This is the issue:

1. I upgrade my D6 site and all it´s contrib modules to latest D6 versions.

2. I disable all contrib modules.

3. I try to upgrade to D7, the same way I usually upgrade (deleting old core files and adding the new ones).

4. After upgrading everything, and run the update.php script, I encounter that all my admin pages show a message “You do not have any administrative items”. I´ve read several posts about this error, and decide to run the update script again, because it probably didn´t finished.

5. That was true, I´ve had 14 updates pending. So after running the script again, this error appears:

Update #7061: Failed: DatabaseSchemaObjectExistsException: Table system_update_7061 already exists. in DatabaseSchema->createTable() (line 657 of /home/public_html/includes/database/schema.inc). So after reading that this is some sort of a Drupal unresolved bug, I delete that table (system_update_7061), so it can create it again.

6. I run the update script again and found a new error:

System Update #7061: Failed: PDOException: SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry 'public://proyecto.zip' for key 2: INSERT INTO {file_managed} (fid, uid, filename, uri, filemime, filesize, status, timestamp) VALUES (:db_insert_placeholder_0, :db_insert_placeholder_1, :db_insert_placeholder_2, :db_insert_placeholder_3, :db_insert_placeholder_4, :db_insert_placeholder_5, :db_insert_placeholder_6, :db_insert_placeholder_7); Array ( [:db_insert_placeholder_0] => 1889 [:db_insert_placeholder_1] => 1 [:db_insert_placeholder_2] => proyecto.zip [:db_insert_placeholder_3] => public://proyecto.zip [:db_insert_placeholder_4] => application/zip [:db_insert_placeholder_5] => 22989 [:db_insert_placeholder_6] => 1 [:db_insert_placeholder_7] => 0 ) in system_update_7061() (line 2816 of/home/public_html/modules/system/system.install).

So, I´ve read in a post that this error could happen because of a problem with files that have caps letters, and that they can be considered duplicate, etc. So, after trying a lot (I´ve changed the filename, the uri, the fid and the uid associated to that file), I decided to delete that entry.

7. I run again the update script (after deleting the system_update_7061 table, because it was recreated when I tried to upgrade the second time), and found the the same error appeared again. So, the entry was there again! It was re created but I´m in square one again, because the error persists, and each time I try to delete the entry, it is recreated by the script, before it can finish. I must add that, yes, the /admin pages do still tell me the nasty message “You do not have any administrative items”.

8. Please note that I´ve followed the instructions here (Drupal 7 and the "You do not have any administrative items" error), and while I can access the menu links from admin/structure/menu/manage/management, I still get the error message under admin/ link. I´ve cleared the cache and nothing happened. And I´ve checked the admin/modules link and ALL contributed modules are "incompatible" with Drupal 7, when I upgraded them!!

What can I do?? Please help, any insight will be very much apperciated!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.