0

As i am update my durpal version 6.20 to 6.26 and it gives these error after updating.

   1) Fatal error: Class 'Browser' not found in /opt/lampp/htdocs/mydrupal/includes/common.inc(1731) : eval()'d code on line 4

   2) warning: include(Browser.php) [function.include]: failed to open stream: No such file or directory in /opt/lampp/htdocs//opt/lampp/htdocs/uls/includes/mydrupal/includes/common.inc(1731) : eval()'d code on line 3.

I checked the common.inc file and there is no code for "including browser.php"

1 Answer 1

2

The error message says eval()'d code on line 4. You have a PHP block, node or something similar that tries to include a file called Browser.php. That is not a file supplied with Drupal core. What you can do... just before line 1731 add something like if(strpos($code, 'Browser.php')) { file_put_contents('/tmp/log', print_r(debug_backtrace(), TRUE)); exit;} and then study the log to see where it's called from to figure it out. If it's called from block, the backtrace will contain the module and delta, if it's a node, the nid will be there and so on.

5
  • thanx for reply... one thing more i noticed just now that problem is with my custom theme.. not with garland theme. Aug 13, 2012 at 7:39
  • That's probably because it is a block that is only shown in your custom theme. Check your custom blocks that are enabled on that theme. Or disable the PHP filter then you should see it.
    – Berdir
    Aug 13, 2012 at 8:36
  • @chx thankx buddy you saved my time.. :D i found the code in view.. Aug 13, 2012 at 9:07
  • sorry but i dont konw how to do that please tell? Aug 14, 2012 at 6:27
  • i39.tinypic.com/5evj1e.jpg
    – user49
    Aug 14, 2012 at 9:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.