4

When I edit something in CKeditor and insert a list, the bullets or numbers are not rendered in the result.
Is it possible to correct it?

2

CKeditor uses CSS from either your default theme or it's own stylesheet. If you are are using your site theme maybe it is set to hide the bullets and numbers.

  • I don't have it defined in my CSS file. – xralf May 23 '11 at 15:44
1

I had the same problem. It was related to my theme css. I solved it by changing the ckeditor css editor settings under admin/config/content/wysiwyg from "use theme css" to "editor default css".

0

Are just the bullets not showing up or the list itself. ie is it putting or tags within the content result? If not it may be an issue of your input format stripping out the tags.

If the tags are there then the bullets or numbers showing up is most likely a css issue. look for list-style: none; for example.

  • I'm not using IE I'm on Linux. There is list-style-type: none. I can change it firebug but don't know where to change it forever. – xralf May 24 '11 at 7:08
  • Sorry I didn't mean IE I meant for example (i.e.) You can use firebug to find out the id or class which list-style-type: none; is being set on and then override it in your .css file – Teegan May 24 '11 at 7:10
  • For example if list-style-type: none; is set on the body you can do something along the lines of body { list-style-type: circle; } – Teegan May 24 '11 at 7:12
  • Thank you I will try it, but it would be great to change it directly in CKeditor and its own stylesheet. – xralf May 24 '11 at 7:59
  • From my understanding CKEditor's stylesheet works fine out of the box with list styles. I think it's generally outside stylesheets (unrelated to CKEditor) which actually set list-style-type to none and override CKEditor's styles. It may be a problem of another module's stylesheet setting it to none. – Teegan May 25 '11 at 6:11
0

If you're using your own theme's CSS styles (which is often a great idea!) make sure you're not embedding HTML elements within elements that might not exist in CKEditor. For example, this:

.node-inner ul li { list-style-type: disc; }

will never show up in CKEditor because there's no <div class="node-inner"> within it. You'll need to just use ul li {...}.

Sometimes I create a "ckeditor.css" file in my theme that defines only the styles I care about in this context, such as those that would appear within the body of a node.

0

Add

list-style-position: inside;    

to your ol, ul css

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.