0

Upon running drush pm-list --type=module --status=enabled | sed '/\((.*)\)/!d;/[Cc]ore.*-.*[Rr]equired/d;s/.*(\(.*\)).*/\1/' | sort > noncoremod.txt

I got this error:

The following extensions will be disabled:
.........
Do you really want to continue? (y/n): y
array_merge(): Argument #2 is not an array content.install:42        [warning]
array_merge(): Argument #2 is not an array content.install:42        [warning]
array_merge(): Argument #2 is not an array content.install:42        [warning]
array_merge(): Argument #2 is not an array content.install:42        [warning]
.........                                                            [warning]
Table 'profile_fields' already exists                      [warning]
query: CREATE TABLE profile_fields (
`fid` INT NOT NULL auto_increment, 
`title` VARCHAR(255) DEFAULT NULL, 
`name` VARCHAR(128) NOT NULL DEFAULT '', 
`explanation` TEXT DEFAULT NULL, 
`category` VARCHAR(255) DEFAULT NULL, 
`page` VARCHAR(255) DEFAULT NULL, 
`type` VARCHAR(128) DEFAULT NULL, 
`weight` TINYINT NOT NULL DEFAULT 0, 
`required` TINYINT NOT NULL DEFAULT 0, 
`register` TINYINT NOT NULL DEFAULT 0, 
`visibility` TINYINT NOT NULL DEFAULT 0, 
`autocomplete` TINYINT NOT NULL DEFAULT 0, 
`options` TEXT DEFAULT NULL, 
PRIMARY KEY (fid), 
UNIQUE KEY name (name), 
INDEX category (category)
) /*!40100 DEFAULT CHARACTER SET utf8 */ database.mysqli.inc:169
Table 'profile_values' already exists                      [warning]
query: CREATE TABLE profile_values (
`fid` INT unsigned NOT NULL DEFAULT 0, 
`uid` INT unsigned NOT NULL DEFAULT 0, 
`value` TEXT DEFAULT NULL, 
PRIMARY KEY (uid, fid), 
INDEX fid (fid)
) /*!40100 DEFAULT CHARACTER SET utf8 */ database.mysqli.inc:169

array_merge(): Argument #2 is not an array content.install:42        [warning]
array_merge(): Argument #2 is not an array content.install:42        [warning]
array_merge(): Argument #2 is not an array content.install:42        [warning]
array_merge(): Argument #2 is not an array content.install:42        [warning]
.........                                                            [warning]
There was a problem disabling                                        [error]
comment,contact,help,locale,menu,path, .....

After that I go to admin/build/modules to check the modules state but I was being surprised by seeing that all the modules are enabled.

Any thoughts?

Related issue: http://drupal.org/node/523384

7
  • What does drush --version output?
    – Citricguy
    Aug 20, 2012 at 23:45
  • @Citricguy drush version 5.2
    – user8012
    Aug 20, 2012 at 23:58
  • I'm experiencing this too. No answer on top of my head until now. Aug 21, 2012 at 2:04
  • @ninjascorner are you on 5.2 as well? Drush is currently in version 5.7. Could you confirm that this is still broken in 5.7? drupal.org/project/drush
    – Citricguy
    Aug 21, 2012 at 3:22
  • Yes I'm using 5.2. Ok I will try 5.7. But is this caused really by Drush? Aug 21, 2012 at 4:41

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.