1

I am having trouble saving my block regions(admin/structure/blocks).

Problem: I am doing my thing on block admin page, saving blocks, moving them around and what not. but the changes i make are not being saved.

What i found: after some debugging efforts, i figure out that the function *block_admin_display_form_submit* is not called when the block form submits.

the site i am having problem is on a lamp server somewhere. i have another copy of this site on my local machine, which has no problem saving block regions.

any idea on how to fix this? thank you.

0

I'm having the same issue, I cannot call function block_admin_display_form_submit($form, &$form_state).

I've set a custom variable that should be updated if I change block region.

Everything works if I do it from the block edit page(admin/structure/block/manage/menu_block/ID/configure), but if I try to do it in the block admin display form (admin/structure/block), It will not work.

I've tried to increase max_input_vars with no success.

Have you solved it?

  • 1
    i fixed it by increasing max_input_vars. – Funky Dude Jun 20 '13 at 15:54
  • I've managed to make it work. I was not calling the function in the proper way. Btw, I had already increased max_input_vars previously and I have tried to decrease it yet. I will let you know. Thanks – Tyler Durden Jun 20 '13 at 20:39
  • I can confirm it. It works without max_input_vars incresed. It's an Ubuntu server 12.04. In my php.ini I've got - ;max_input_vars=1000. – Tyler Durden Jun 20 '13 at 22:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.