2

I made a calendar view that displays all my events. When I created the view the content type Events wasn't enabled for repeating dates.

But now I do want repeating dates, so I enabled the repeat date modules en settings in the content type.

So when I input repeated dates it shows correctly in my node buildmodes but it doesn't show the repeats in my calendar only the first one. Can I still change the calendar to display repeated dates?

Thanks in advance

UPDATE

There's an issue in the date module The last solution is for drupal 6 I think because I can't find Global Settings of 'Number of values as 1' in Drupal 7 http://drupal.org/node/1391464

solution

I had to delete my field_event_date and recreated to be repeating I only lost my dates instead of my full nodes.

  • The distinct option is off in the query settings of my view, so that shouldn't be the problem – Damian Aug 24 '12 at 8:47
1

After deleting and recreating the date field on your content type (as in the Original post), re-add it to the list of fields in the Views context filter (Date: date(node)).

0

Edit your user permission settings to allow display of repeat dates.

  • That didn't solve my problem but it might of prevented future problems so thanks anayway – Damian Aug 24 '12 at 9:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.