1

I am using Drupal 7.

I have installed Boost module and configured properly as per the guidelines from Drupal.org site and other sources.

As per my knowledge to test whether boost is working or not we have to check html source code of any page because Boost module adds Boost tags in the html output generated by drupal.

When i check page source i don't find any boost tags.

I also have one doubt regarding the configuration, in .htaccess generation page there are three options

%{HTTP_HOST}

%{SERVER_NAME}

localhost

which one should i enable when i am configuring on the site like http://xyz.com/mydrupal where mydrupal contains drupal setup and all the files

1

%{HTTP_HOST} is the default and it usually works. The other 2 options are there in case http_host doesn't work. Every hosting environment is different; that's why there are options.

| improve this answer | |
1

There are two possible reasons:

  1. Some browsers may not display the Boost tags. Check, if HTML files are saved to the cache directory. If so, it caches, but the tags are not displayed
  2. Check, if you put the Boost htaccess snippet really at the right place in your .htaccess file. It should be added right after

        # If your site is running in a VirtualDocumentRoot at http://example.com/,
          # uncomment the following line:
          # RewriteBase /
    
| improve this answer | |
0

One more possible reason is the directory permission of cache. Set <drupal-root>/cache permission to 777, then visit any page on the site. If everything is ok then you can see cached page copy on below path

<drupal-root>/cache/normal/domain-name/

This way you can verify which page is cached and which is not.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.