2

I have created full text search in webforms using Search Api and its working fine earlier but when i added some new records, the new records are not indexed and not able to displayed them on view. I don't know why new records are not indexed.

2

You'll need to re-index the site when new records are being added. You can do it by visiting http://your-site-url/admin/config/search/settings and click "Re-index site".snap

P.S: This will queue the items for re-indexing. The items will actually be re-indexed when "cron" runs for the next time (manually or scheduled cron job.

  • I have done this but it says "0% of the site has been indexed. There are 42 items left to index." – Pramod Kumar Sharma Sep 3 '12 at 5:38
  • that is because doing this will queue the content for re-indexing. The actual re-index is done when the "Cron" is run next time. Run cron manually at yoursite/admin/config/system/cron and later you'll find that your site is completely indexed and your content begins to appear in the search list :) – AjitS Sep 3 '12 at 5:45
  • Thanks for the reply ...Its works for rest of the content but in webforms its still showing the same old records....:( – Pramod Kumar Sharma Sep 3 '12 at 5:51
  • is there any other way to apply full text search for webforms as its not working – Pramod Kumar Sharma Sep 3 '12 at 6:00
  • the default search API doesn't give much options to customize. You could try using Apache Solr framework which give good options to customize the indexing. A good tutorial for the same can be found at web3us.com/drupal6/how-create-web-site-handbook/… – AjitS Sep 3 '12 at 6:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.