1

I am trying to do a simple CSV import into a node using the Drupal Migrate module. I have created the .module and .info files and double-checked them against several examples online. I have also created a .inc file including

class CrfmMigration extends Migration

I have enabled my module from the Modules Administration panel and there are no errors. However, when I go to the Migration UI, my migration class isn't listed at all. The Beer and Wine samples show up just fine, but my custom migrate class is nowhere to be found. I'm not even sure which file the problem could lie in. I am more than happy to provide any additional information as necessary to figure this out. I prefer not to use Drush if possible, but I will if there is no other option.

  • try clearing your drupal cache – Attiks Sep 6 '12 at 17:58
  • Can you share your migration module code, for example via pastebin.com ? – tog22 Nov 16 '14 at 10:36
1

This might happen for a couple of reasons. Here are some pointers:

  • Make sure your module implementing the migration is enabled (I believe you must have checked that already).
  • Make sure your migration classes are registered with Drupal using the files directive in the .info file.
  • Make sure you clear the cache, especially the class registry.

I hope it helps! I'm currently stuck in a D8 migration.

|improve this answer|||||
  • I was missing the files entry in .info (doh) – autopoietic Nov 8 '17 at 9:40
  • Great, so does this imply that my answer worked? Or was there anything you had to fix? – Jigarius Nov 10 '17 at 19:45
0

This is usually an issue of needing to clear your cache. Usually if you register a migration class with migrate and then view a migrate UI page without having cleared the cache, you'll see an error about your migration class no longer existing.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.