I have a problem since few days and i didn't find my answers.

When i install content access, the permission View own unpublished content doesn't work anymore.

Some explanation about my configuration:

I use workbench and workbench moderation to create a simple workflow (i didn't change any setting: so draft, in review, published)

I have 2 roles who manage all the content (editor, manager and another role admnistrator who has all the bypass etc.)

And now, i've juste discovered that i have a problem when i need to see nodes that are not published. Editor and Manager can't see them event if they have created this content.

They can't see unpublished content everywhere in the site (in workbench administration and in content section so it's not a views problem)

I made another installation in local to make some test. I re-created my role with a basic configuration (permissions):

  • Access administration menu
  • Access the content overview page
  • View own unpublished content
  • View the administration theme

So when my manager creates a content type and it's unpublished it works fine. But when i install content access, it doesn't work anymore.

I don't know what's going wrong in my site but the only way for the user to see unpublished content is to have that permission : Bypass content access control

Problem, if i give them that permission, an editor can published content. It's override the workbench permission (he can just use draft and in review, only manager can published)

The only setting for content access i saw are in the content type section. content access

I think i made a stupid mistake, forget a setting but i didn't see where.

Thxs for your help :)

2 Answers 2


I've just found some interesting information about my problem. Maybe it will help someone else.

In fact, it's seems impossible to resolve this problem in a proper way.

There is a very good article about that: Access Control module prevents View of user's own unpublished content, and an issue on drupal.org

If we want to see our own unpublished content in workbench, we have to go in view and make:

  • Go to query settings
  • and check Disable SQL rewriting option

It's not very good solution like he said but we can't do anything else for now.

  • Its working thanks ... hope we will find a better solution in future. Actually its not problem with only content access module even with-out installing it you will find same problem if your content access permission has been rebuilt by other modules like og-content-access, workflow, etc. I don't know where is the problem but after rebuilding (overriding) content access permission views became unable to show unpublished contents to no-administrative user roles.
    – user12427
    Jan 2, 2013 at 19:36

I actually have an answer for you!

I had run in to this issue on a site and was about to just give everyone bypass access permissions, when it clicked that the only reason users can't see the unpublished items is because the view that's driving the default Content admin page doesn't know about Workbench Moderation's states.

The solution therefore is to override the default Content page, and the easiest and most effective way to do that is to install Administration Views.

Administration views replaces the default content view and ootb this view supports the permissions workbench moderation provides. Your problem is now fixed!

Note that Administration Views requires Views, Views Bulk Operations, Chaos Tools and Entity API, but if your site doesn't have most of those already you're probably doing Drupal wrong!

If you don't want to allow any of the VBO functions (because they tend not to play nice with Workbench Moderation in my experience) you can just hide that field in the view, or disable all the actions you don't want people to use.

Not the answer you're looking for? Browse other questions tagged or ask your own question.