6

I have a new drupal install. The only modules installed so far are devel and ckeditor.

I've added the 'styles' dropdown button and successfully directed it to the ckeditor.styles.js in my theme directory. At the moment, I'm using a path without tokens.

Initially, I had it at the root of the theme: /sites/mysite.org/themes/mytheme/ckeditor.styles.js

but, when I updated the file in that location, the styles dropdown did not change. I tried resaving the ckeditor and I tried clearing all caches (from the performance section), I tried re-editing and saving the .js file (and I tried several permutations of the order); but, the dropdown would not update. I have browsed directly to the .js file after changing to confirm that it has updated

Eventually, I discovered that the only way to get the styles dropdown to update was to place the ckeditor.styles.js file in a brand new location (each time I want it to update).

So, if I change it I need to move it to:
/sites/mysite.org/themes/mytheme/includes/ckeditor.styles.js

and if I change it again, I need to move it to:
/sites/mysite.org/themes/mytheme/includes/ck/ckeditor.styles.js etcetera

This seems inefficient and I'm sure there must be another way. Please let me know if you have insight into this issue. Thanks


EDIT

I was originally experiencing this issue while using the 'ckeditor' module. I've switched to the 'wysiwyg' module and I am not experiencing the problem any more.

  • I noticed the exact same issue. It's definitely no browser cache issue. Solved it like you did: Always put the edited config file to a new custom location. It may have to do something with ckeditor's timestamp appended to the files: stackoverflow.com/questions/14940452/… – leymannx Dec 7 '14 at 13:59
6

I believe this is due to your browser cache, not drupal cache. If you clear your browser cache or go incognito in chrome you should see your changes.

  • 1
    I really don't think so. I develop constantly and all of my browsers have cache disabled – Mark Apr 17 '13 at 19:24
  • You can even load the same site in different browsers. All of them will have the same query added to their CKE JS. So it's definitely no browser issue. – leymannx Apr 1 '15 at 13:51
1

I wrote a small module to set CKEditor.timestamp = +new Date which then is queried to the JS so only the freshest JS is loaded on browser reload during development. For me this works super fine.

0

I believe that in addition to clearing the cache of Drupal (and potentially the browser), you should also manually run CRON, which might otherwise take hours to be triggered automatically.

To do that, go to /admin/config/system/cron and press Run Cron.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.