11

I've got a Views Page showing Article teasers. There are lots of Articles in the db and I'm only showing 5 per page in the View, but the Pager is not showing up at all. Here is my Views configuration, am I doing something wrong? Is there a bug?

enter image description here

The preview in the Views screen does not show a Pager at the bottom of the content teaser and it also doesn't show on the real page.

Any ideas?

  • Can you add, on the header of the view, the results summary for the view? And what happens if you change the content from teaser to fields? – arrubiu Sep 16 '12 at 20:11
  • Under "Advanced -> Theme" are any of the templates overridden? Or does /most-recent have a template applied? – Citricguy Sep 17 '12 at 2:04
  • Just to be clear - are you sure that you have more than 5 articles that are published? – schnippy Sep 17 '12 at 3:49
  • When I add a Results Summary in the Header it shows "Display 1 -5 of 14" so I definitely have more content. – Kenny Wyland Sep 17 '12 at 6:38
  • 1
    If I switch over to use Fields instead of Teasers, the pager DOES show up (wth?) but, of course, I've lost all of the styling that came with my theme on the teasers. I'd really prefer not to have to restyle EVERYTHING just because of what appears to be a bug. Any help? – Kenny Wyland Sep 17 '12 at 6:49
12

This can have a whole bunch of reasons. I'm just providing the imho most probable non-obvious one:

Go to "pager settings" (on your screenshot click "Paged, 5 items") and change the "pager id". Docs say this is only needed when there is more than one view on a page, but i saw live examples where this fixed a non-showing pager on a single-view page.

  • I have long since fixed whatever page I was working on for them, but I believe this comment strikes at the heart of the problem I had (even though I solved it differently), so I'll accept it. – Kenny Wyland Dec 17 '12 at 18:48
  • @KennyWyland could you please provide ur soln. too. Thanks. – SGhosh Feb 18 '13 at 8:45
  • 1
    This was the right answer for me! I had recently included another view on the page, and apparently there was a pager id conflict. – daggerhart Apr 19 '16 at 18:32
11

I came across this issue recently since upgrading to views 3.8. for me the issue was caused by views_php module as discussed here: https://www.drupal.org/node/2276165 there is also a patch available to fix it.

0

The solution described in the answer from aexl worked for me.

For those who don't understand that answer, maybe this refined version of it helps:

Go to "pager settings" (on your screenshot click "Paged, 5 items") and change the "pager id" to something like 5 or any number instead of leaving empty.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.