0

I've on a Drupal 6 site which run since 2 years, a new problem at first with CloudZoom but i start to think that it's a little more than that.

I've errors in the firebug console which says : Uncaught TypeError: Object function ... has no method 'cookie' or Uncaught TypeError: Object function ... has no method 'cloudzoom'

So Cloudzoom don't works anymore on some language... what is strange is that it still work in english.

I've take a look at the code and it's ok, it worked in the past ans still work in english. I also make sure that JS file are call in the right order jquery>librairies>myOwnJs.

what i need is to understand the error message "Uncaught TypeError: Object function" : what can generate that kind of error, where to search. I spend a lot of time on that and don't really know where to look now.

  • I answer my own question because i've found the problem, but still not the solution :( . I've a web service that add a version of jquery if mine is different and on my drupal site i've a module which add the last version of jquery : so i've two jquery on my page (and it's not good). English version works well because it's not using that web service. So now i've to find how handle that situation. – SavaryNicolas Sep 20 '12 at 13:23
1

You got it - basically it means the function isn't defined or is conflicting. You have to load the jQuery file that you're going to use and not multiple or you'll get that type of strange behavior.

The workaround I've used, which does work -- assuming you're not using that particular function -- is to define the function yourself as an empty function and it'll reference that and just keep on going. This came up in the Adobe Edge beta as fnCycle() was giving the same error. After putting the empty function in my own .tpl.php is solved and didn't kill the js execution.

Note though that while this may work for that one situation, you will have others if you leave conflicting versions of jQuery in there.

  • Finaly it's solved, i call the team in charge of the web service and they fix it. I'll keep your advice in mind because i can't contact each team which provide a webservice. Thank you. – SavaryNicolas Sep 27 '12 at 11:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.