0

I've got a big problem this morning.

I'm working with english as default language Administration » Configuration » Regional and language. It's much more easy to me to work with the interface in english.

But this morning i have to change the default language to french because my boss want the interface in French (and the website is almost finished)

But unfortunately, all my alias doesn't work anymore like before www.example.com/my-article is becoming www.example/node/5. More precisely, it's only alias from content type who doesn't work fine because taxonomy term are ok.

Does someone has a idea why when i changed the default language in Administration » Configuration » Regional and language (english to french) my alias didn't worked anymore?

2 Answers 2

1

when you enable translation you can translate a node to that language, as all your nodes are in english, there is no real french node for that.

obviously the path-alias is not taken.

you need to copy all nodes to have them in french too, just hit translate while editing a node, upper right.

there is also the i18n module giving you more translation options.

2
  • Thxs, i install i18n and i will run some test later in the day.
    – Epok
    Sep 27, 2012 at 10:12
  • if you only want to have one language i would not install i18n
    – rémy
    Sep 27, 2012 at 10:16
2

This happens because the table url_alias has a language property that doesn't match anymore with the default language. Try to change the language code to your default language or delete the information. (Of course, make a backup before in case of).

1
  • Thxs i will run some test on my back-up server later in the day.
    – Epok
    Sep 27, 2012 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.