3

I have moved an entire drupal site to another server. While everything else seems to work fine, I can't quite access collapsed fieldsets in Views UI anymore. It looks like this

enter image description here

All fieldsets (STYLE SETTINGS and so forth) are collapsed. The fieldset label however is not a link. The content of the fieldset exists when I view the HTML of the site. If I remove the CSS

html.js fieldset.collapsed .fieldset-wrapper {
  display: none;
}

I can again see the fieldsets' contents, but the error must be somewhere else. But I don't have any clue where to look for. Anyone has an idea?

I tried to google the error, but it seems all known errors are related to some "Expand all" or "Collapse all" buttons.

  • 7
    Are you using jQuery Update? If so, you should upgrade to dev version and select 1.5 for admin pages. It removes a LOT of Views UI problems caused by jQuery Update and even if it will not solve your issue, it will at least give a clear ground for debug. – Mołot Jan 8 '14 at 8:35
0

This probably means that there is something wrong with JS making collapsible not work.

Is there anything in the JS error log? Check if all JS files are moved and that they are complete. Also check for error 404 for JS files.

  • All files are moved, neither Firebug (FF) nor DeveloperTools (Chrome) show any issues. – Paul Sep 28 '12 at 11:04
  • Check for errors after you click on the collapsible div. Try disabling/enabling the views and cleaning the cache between. – Aram Boyajyan Sep 28 '12 at 12:16
  • 1
    I've also seen issues with Views UI along the same lines. Never had the time to track them down though the site in question has a lot of enabled modules. If I did have the time I'd look for modules that implement views hooks that might have done so incorrectly. – Alfred Armstrong May 29 '13 at 9:22
0

usually this is a js error that comes when you install jquery_update

go to jquery_update settings and make the jquery for admin less than version 1.10 probably 1.7 will work

make sure you clear cache

0

Navigate to /admin/config/development/performance. Clear the caches. If any of the JS files are aggregated and/or minified, clear those caches as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.