4

I have a content type with a field that has been set to inactive. This happened after I reverted my feature in an attempt to undo a change I made to the content type.

The error message given is the following:

This content type has inactive fields. Inactive fields are not included in lists of available fields until their modules are enabled.

I've disabled and re-enabled the feature module, but the field is still inactive.

How can I activate my field?

4

I've had this quite a few times, I'm not sure what the initial problem is but I've solved it by doing either one of the following:

  1. Disabling the feature and re-enabling it
  2. If above fails disable delete content type then re-enable (not an option if there existing content on the site)
  3. Manually editing the content_field_instance table (D6) and enabling it there.
| improve this answer | |
1

Try: http://drupal.org/project/cck_manage_inactive.

Once you activate the module, the module will expose a new tab: "Manage inactive fields", on the content type administration page, usually: admin/content/node-type//fields-inactive.

It will allow you to completely remove, or re-activate the field(s).

Good luck!

| improve this answer | |
0

Everything related to fields configurations is inside field_config table. All the following columns should be correct for field to appear in entity/content type fields list : active : must be 1
storage_type : sql_field_storage or an alternative
storage_module : sql_field_storage or an alternative
storage_active : must be 1
deleted : must be 0

| improve this answer | |
  • This solution is for Drupal 7 by the way – Sina Salek Oct 11 '12 at 8:36
0

"I fixed the problem by turning off ALL CCK modules and then turning them back on." http://drupal.org/node/883354

It seems that when I upgrade the core of Drupal, somehow the CCK modules where, automatically, activated before other modules that enable special field types.

| improve this answer | |
0

This is a really old question but it was the one I kept finding whilst soul searching on Google.

I was observing the same as OP. Most fields wasn't being displayed.

I was also seeing this on lots of pages.

Invalid argument supplied for foreach() in field_attach_load() (line 660 of /var/www/vhosts/hicrowds.com/httpdocs/qa.hicrowds.com/modules/field/field.attach.inc)

All the modules providing the fields were enabled.

When flushing the cache via Drush and the UI, it kept throwing a site error.

So I tried truncating all the cache tables manually. Still had a few errors but less, so I re-saved the modules page. Then finally all the fields appeared again.

So something else to try I guess if you're hitting this.

| improve this answer | |
-1

Check the content_field_instance_delete() function.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.