1

has anyone else come across this? I'm getting an error when I'm trying to create a product display. It happens when I'm trying to put in the product SKU.

An AJAX HTTP error occurred.

HTTP Result Code: 200

Debugging information follows.

Path: http://hayfield.com:8082/commerce_product/autocomplete/node/field_product/product_display

StatusText: OK

ResponseText: {"glorious_dream":"\u003Cdiv class=\u0022reference-autocomplete\u0022\u003Eglorious_dream: Glorious Dream\u003C\u002Fdiv\u003E", "Hayfield_Elegance":"\u003Cdiv class=\u0022reference-autocomplete\u0022\u003EHayfield_Elegance: Hayfield Elegance\u003C\u002Fdiv\u003E"}jQuery.extend(Drupal.settings, {"thmr_1":{"id":"thmr_1", "name":"link", "used":"theme_link", "type":"func", "duration":2.78, "candidates":[ "hayfield_link" ], "preprocessors":[ ], "processors":[ ]}, "request_id":"1852760308506e2eabeea31", "devel_themer_uri":"\u002Fdevel_themer\u002Fvariables\u002F1852760308506e2eabeea31"});

Thanks in advance!!

  • 1
    You got something mixed up, HTTP 200 means that the request was OK (no errors). Whatever your problem is, it's not possible to detect in the data given. Posting the raw contents of an AJAX call would not be of much help anyways, unless an error moessage was actually displayed. – googletorp Oct 6 '12 at 12:02
  • YIKES! So I'm not quite sure how to fix it. It's still able to link the SKU when I type it in but I get a million of those "error" boxes. .. Would a change to the PHP preprocessing code cause a AJAX error like that?? – everaftergraphics Oct 6 '12 at 19:40
  • 1
    Theme, library, preprocess code. Check what you've modified. – Bojan Zivanovic Oct 7 '12 at 23:16
  • BRILLIANT!!! I downloaded and copied over the original zen preprocess file and it works!! I must have edited that preprocess file by accident instead of the one in my subtheme. – everaftergraphics Oct 9 '12 at 13:22
  • @BojanZivanovic & everaftergraphics - could you post that as an answer if it works? – Mołot Oct 2 '13 at 14:28
0

I've seen this error before, you should start from scratch with the latest release candidate for Drupal Commerce, located here: http://drupal.org/node/1786764. This fixes the AJAX bug.

  • Drupal Commerce has no release candidates at this moment. Perhaps you meant -dev version? – Bojan Zivanovic Oct 7 '12 at 23:16
  • I have the latest Drupal Commerce installed. I tried installing the brand new Commerce Kickstart but it throws errors right off the bat and it's so different that it's like starting from scratch. What is the -dev version? – everaftergraphics Oct 8 '12 at 3:10
  • I was specifically referring to the Commerce Kickstart 2.0-rc1 version. Located here: drupal.org/node/1786764. I've updated my post. – generalconsensus Oct 8 '12 at 3:49
  • So how did you migrate from one to the other? It's driving me nuts with all kinds of fatal errors and I can't find any documentation to help me migrate between the two. I installed a clean version of Kickstart 2.0-rc1.. but if I migrate over my database and theme - I get hit with a ton of errors. – everaftergraphics Oct 8 '12 at 16:38
  • I really don't know how you would go about that, I would post this in the issue queue for Commerce Kickstart – generalconsensus Oct 9 '12 at 6:01
0

I think this error occurs when some of your modules are outdated. Have a look at your modules, also the Ajax is sometimes having problem with devel modules. Disable devel module and then check it. Good luck.

0

Theme, library, preprocess code. Check what you've modified. – Bojan Zivanovic

Thanks to Bojan I downloaded and copied over the original zen preprocess file and it works!! I must have edited that preprocess file by accident instead of the one in my subtheme.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.