2

Possible Duplicate:
How do I update jQuery to the latest version I can download?

In Firefox I get an unresponsive script error from Google hosted jquery but can't echo the problem on other browsers.

I just looked at the source of drupal and it's loading v1.4 of jquery automatically. I applied my own Google Hosted link to jquery v1.8 in html.tpl.php so in the page is loading 2 versions of jQuery.

I think this could be the reason for the crash. In any case, I still want to remove the redundant script.

How would I go about removing the the automatically added jquery script? I want to print $scripts as some modules have dependents there.

2
  • No i don't want to update Drupal jquery. I want to use google hosted jquery so I want to remove core's output of jquery script in the header. Oct 7 '12 at 17:37
  • Make sure you read the linked answer fully, it'll tell you how to remove the core jquery files
    – Clive
    Oct 7 '12 at 17:51
2

You should use jQuery Update module. Here is a quote about it (from the module's project page):

Upgrades the version of jQuery in Drupal core to a newer version of jQuery.

Updates:

  • Drupal 5 to jQuery 1.2.6
  • Drupal 6 to jQuery 1.3.2
  • Drupal 7 to jQuery 1.5.x, 1.7.x, 1.8.x, 1.9.x, 1.10.x and jQuery UI 1.10.2
  • Drupal 8: TBD

Not the answer you're looking for? Browse other questions tagged or ask your own question.