1

Im using Linode VPS but mails are routed via SMTP authentication to Google. Email is sending correctly and I'm using mail system and html mail with smtp authentication.

When I send test email as html to test mailbox, it shows markup and wont render to html. How can I fix this?

HTML Mail > Send Test

Creating HTML mail and sending it with SmtpMailSystem sending class. Output when viewed at gmail receiving it:

<p>This is a test letter.</p>
<p>Lets add some <u><strong>html</strong></u></p>

So all markup is visible. What I'm missing?

  • 2
    Headers are wrong perhaps. Can you re check headers ? – GoodSp33d Oct 7 '12 at 16:51
1

Fixed.

Edited php.ini: /etc/php5/apache2 # nano php.ini

-->

; For Unix only. You may supply arguments as well (default: "sendmail -t -i"). sendmail_path = /usr/sbin/sendmail -i -t

Set mailsystem to htmlmail, voila.

  • Can someone clarify this a little? I don't think php.ini needs to be edited (and this comment doesn't seem to actually represent any changes to php.ini - unless @Tumomas is resetting the default). And "Set mailsystem to htmlmail" is an insufficient description of the configurations for the mailsystem module. This does look like the right track, but i'm having trouble understanding what the OP intended. – doub1ejack Jan 10 '14 at 16:19
  • I think this answer says the same thing a little more clearly. – doub1ejack Jan 13 '14 at 15:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.