0

Just that. I changed the front page to "my-front-page". Now if I go to the front page the fields for this node aren't shown at all. Just the blocks are shown.

I guess there is a preprocess function related to the front page. The only one that I see is this one, but nothing happens if I delete this function:

function commerce_kickstart_theme_alpha_preprocess_page(&$vars) {
  if ($vars['is_front']) {
    unset($vars['page']['content']['content']['content']['system_main']);
  }
}
3
  • What do you mean by "the fields for this node aren't shown at all" ?? – Anil Sagar Oct 9 '12 at 9:17
  • The node I set as <front> is a 'basic page content type' node. This content type has a 'body field'. In this body field I put some text. When viewing the front page the 'body field' is not shown. I already checked 'manage display' for this content type and the body field is enabled. – chefnelone Oct 9 '12 at 10:55
  • I think it must be a preprocess function or a template file, but I can't find it. – chefnelone Oct 9 '12 at 11:00
0

It looks like this preprocess function needs to be changed in the parent theme.

In this case it can be found in the /profiles/commerce_kickstart/themes/omega_kickstart/preprocess folder.

1
  • Yes, I get the same answer in the issue I posted for the distribution. – chefnelone Oct 11 '12 at 6:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.