1

I've set up a Drupal Commerce site without the sample products, and have created new products in a new product displays that I've created.

I've created Main menu items for the new displays, and the products show up when these menu items are clicked, but All Products shows no products.

How do I make All Products work? Is there a special View for this?

  • IIRC there was an issue with the inline entity form, where new product entities were created but set to inactive by default. Check to see if the product entities are set to "active" in store > products. – user842 Oct 10 '12 at 18:12
  • Make sure the products are published (Publish state of the node), and that they have been indexed (maybe your search index is empty). – Bojan Zivanovic Mar 18 '13 at 16:55
1

I know this is old, but I recently encountered the same issue. Bojan Zivanovic's suggestion ave me an idea though. The search index indicated all products were indexed, but clearing the search index and rebuilding it resolved the issue.

0

Due to the way the Kickstart installation was built all products are not visible by default in the product view. You can modify this view by going to /admin/structure/views/view/commerce_backoffice_products/edit and changing the filter and field information for your particular installation.

  • That's the admin view. He's talking about the frontend view. – Bojan Zivanovic Mar 18 '13 at 16:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.