0

i have drupal 7 on localhost (core i7 - 12gb ram etc) on Nginx with APC and mySql on windows7.

standard installation with standard theme and a bounch of new modules. about NO content.

The problem is that the homepage take ever 1,5 sec to load (without APC 3 secs). i installed XDEBUGGER and with winCacheGrind i discovered that 75% of the time is lost in DB connections. Self: 2ms, Cumulative:1007ms screenshot of the winCacheGrind

i tried almost anything i found on google... also i ported db engine to MyISAM... mySql is configured with my-HUGE.ini file... so it can take any resource from the computer.

How could i solve this?

1,5sec for any loggedin user is too much time... on the hosting this time will be greater as i won't have a so big dedicated server...

3
  • try checking the reverse DNS problem, noted here for example lists.mysql.com/win32/17156
    – mojzis
    Oct 11, 2012 at 17:00
  • i probably misunderstood your situation - the above note is especially valid for situations where mysql is on a different server ...
    – mojzis
    Oct 11, 2012 at 17:10
  • yes, my DB is on the same server of NGINX (localhost)
    – Alex
    Oct 11, 2012 at 20:21

1 Answer 1

1

This is a good group for you to join on groups.drupal.org
http://groups.drupal.org/drupal-windows

Looking at this post it sounds like the issue you are describing: http://groups.drupal.org/node/242443.

Make sure that your Drupal settings.php connection string uses the IP address of your MySQL server (e.g. 127.0.0.1 for your local Windows machine), not 'localhost'.

3
  • Wow! Thank you very much! Can't understand why i haven't found that post before! Page load time decreaset very much! Homepage (in admin mode) take now 235ms - A very good improvement! I will test other behaviour!
    – Alex
    Oct 31, 2012 at 8:23
  • @mikeytown2 I merely thought it was worth mention that the localhost to 127.0.0.1 switch should only apply on a Windows machine, on Linux using 'localhost' would use Unix sockets which are more performant than going through the network stack. (I'm aware that you are likely aware of it, but it may not be clear to all users.)
    – Phizes
    Sep 28, 2014 at 7:29
  • You need to specify unix_socket even on Linux reddit.com/r/drupal/comments/2e6h9j/…
    – mikeytown2
    Sep 28, 2014 at 16:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.