1

I've setup Feeds to import content every minutes. All settings was fine. Feed source contains only 1 rss item, and it changed every 1 or 2 minutes.

When I manually click "Import" tab, it will import nicely. But in many times, Feeds too lazy to import it.

By using cron, Is there any way I can force Feeds to import?

  • I would also like to know this. I don't know if lazy is the right word but I would like to import more often than cron runs, I'm not gonna run Cron every other minute... – Karl Jóhann Jun 9 '11 at 11:04
  • @Karl If you made that its own question, I'd happily answer it, but using cron.php vs. not doing so are different enough that they really shouldn't be lumped together. – HedgeMage Jun 9 '11 at 14:47
  • 1
    @Karl you can use the Elysia Cron module to split up your Cron tasks so you could run some every minute and others at different intervals – Chaulky Jun 9 '11 at 20:07
  • If the source has PubSubHubbub support, that's your best bet. – AyeshK Feb 27 '13 at 18:35
1

Check the minimum refresh period in your feeds setting; feeds will not import anything if the last import is more recent than that setting.

1

In the Feeds settings page, in the settings section, check the option 'Skip hash check' -Force update of items even if item source data did not change.

This will prevent the importer from checking for any change, and import every time.

I would also check that the import task is quick enough to happen every minute. Imports can take several minutes, and re-calling the import by the cron every minute may disrupt this.

  • +1. Also, don't confuse with the GUID setting. GUID thing is to prevent duplicate items. Hash check is to make imports faster. – AyeshK Feb 27 '13 at 18:37
0

Create drush command and add it in your crontab file on the server.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.