1

I have view which is displaying only 2 nodes. I add views field view to another view which is display all nodes which are from another content type but with the same date as his parent node. I filter it by contextual filter and everything is working but I have a problem with second parent node. It is display fine but it looks like that it is passing contextual filter from the first parent and to parent 2 view is displaying child from parent 1. Where is the problem? Is it passing contextual filter only one time and after that is it using only this contextual filter? for 1 parent I am passing contextual filter [%field_date] with value 2012-10-13 and it showing me all nodes with this date.. it is good. But for second parent I need value 2012-10-14 and it looks like it is still 2012-10-13 from first passing of contextual filter.

now I have this result

parent 1
    - child 1 of parent 1
    - child 2 of parent 1
    - child 3 of parent 1 ....
parent 2
    - child 1 of parent 1
    - child 2 of parent 1
    - child 3 of parent 1 ....

but I need something like this:

parent 1
    - child 1 of parent 1
    - child 2 of parent 1
    - child 3 of parent 1 ....
parent 2
    - child 1 of parent 2
    - child 2 of parent 2
    - child 3 of parent 2 ....

Thanks a lot for all your replies :)

updated


after hours of testing I thing that there is a problem with passing date from parent field date. When I get it as contextual filter into child view with [!field_date] and after that I use it in header of view with %1 it is blank. I need to use it with !1 paramater and ther it look good. But in contextual filters of child view I cant spcify in which format I want to use parameter. I think there is a problem with sending paramater from parent to child view, but I cant find it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.