When in logged in to my Drupal 7 install as the administrative user, I can't access the "Manage fields" or "Manage Display" for my custom content types.

I've tried all the following with no joy:

  • I've deactivated all my custom modules
  • I've given the admin user all permissions
  • I've flushed the cache, many, many times
  • Logged out and back in

I'm pretty sure I'm not using the hook_drupal_break hook anywhere!

I've got NO IDEA what I've done wrong. It used to work, but now I can't access it.

  • Have you tried rebuilding permissions? /admin/reports/status/rebuild
    – user842
    Commented Oct 17, 2012 at 2:51
  • @nicoz No, I hadn't tried that. But now that I have I can say that it didn't work
    – Coomie
    Commented Oct 17, 2012 at 2:59
  • You get access denied, or page not found? Commented Oct 17, 2012 at 3:02
  • @GaborSzanto /admin/structure/types/manage/%my_content_type%/fields shows the same as /admin/structure/types/manage/%my_content_type%/
    – Coomie
    Commented Oct 17, 2012 at 3:16
  • What does it mean, 'custom content types'? Are you add them via UI, or from some code? When you add a new content type from ui, is the problem still exists? Commented Oct 17, 2012 at 3:28

2 Answers 2


I feel so stupid. But I'm leaving this answer so that the next person to have this same problem will save 3 days of development time:

The module that allows fields to be created on entities (nodes, user etc.) is creatively called "Field".

But, that doesn't mean you'll have a UI to create/edit them. There is another creatively named module called "Field UI". If this modules isn't installed AND enabled you won't have a user interface to edit your fields...


If you did the above answer, and it is still not working - check if you have disabled Developer Modules by hovering the "HOME" in the administration menu and see if it says "Enable developer modules".

Disabling developer modules will disable Fields UI and Views UI.. even if you activate the modules manually you wont be able to edit views or fields - so check if Dev. Modules is enabled.

  • I needed to disable the developer modules first and then re-enable them to make it work.
    – yunzen
    Commented Oct 18, 2018 at 7:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.