0

Anyone having this issue where the wysiwyg editor is only showing when you are in admin mode?

2
  • 1
    did you check the permissions and configure the module ? To configure Go to Administer » Site configuration » Wysiwyg
    – Jayaram
    Commented Oct 19, 2012 at 17:25
  • Yes there is no permissions for using in overlay. Commented Oct 19, 2012 at 17:27

2 Answers 2

1

This is happening because you have an input format associated with the editor that is only available to your admin users. You need to either make the input format available to other roles on your site or expand the formats that the WYSIWYG editor displays on.

2
  • You would think that was the case but I am still logged in as administrator and also changed the text inputs to allow authenticated and anonymous users but still nothing. Commented Oct 19, 2012 at 17:53
  • did you download the library files (Ckeditor, yui editor or any other library supported by the module ? Instead of using the wsyiwig editor, I recommend you to use CKEditor module
    – Jayaram
    Commented Oct 20, 2012 at 2:37
0

The issue is that there is a jquery.once file that is getting loaded either in the overlay module or the administration theme module. I added the js file to my html.tpl file to load in this theme

misc/jquery.once.js

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.