0

Steps to reproduce:

  1. Log in as administrator
  2. Click on People
  3. Click on the Permissions tab

This navigates to admin/people/permissions. Here is the complete source code for that page:

Fatal error: Allowed memory size of 134217728 bytes exhausted (tried to allocate 2048 bytes) in /.../includes/common.inc on line 6300

Why am I getting this error and what can I do about it?

Notes:

  • my php.ini file contains the following line: memory_limit = 128M
  • .../sites/default/settings.php contains the following line: ini_set('memory_limit', '512M');
  • If I go to Reports/Status report and scroll down to PHP memory limit, it says 128M
  • are you using the default/settings.php or you are running a multisite? maybe you have a settings.php other than the one in the default folder – ninjascorner Oct 20 '12 at 1:43
  • @ninjascorner You were right, I am running a multisite and only the settings.php in sites/default/ had the memory_limit instruction. I added it to sites/mysite/ and the problem went away. Would you like to add that as an answer? – Shawn Oct 23 '12 at 16:32
1

If you are running multisite, you probably need to modify your settings.php on each sites.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.