2

When I'm trying to add Content to a panel page (just installed Panels), I get this error message:

An AJAX HTTP error occurred.
HTTP Result Code: 400
Debugging information follows.
Path: /panels/ajax/editor/select-content/panel_context%3Apage-panel%3Apage_panel_panel_context/middle
StatusText: Bad Request
ResponseText: 
Runtime Error
body {font-family:"Verdana";font-weight:normal;font-size: .7em;color:black;} 
p {font-family:"Verdana";font-weight:normal;color:black;margin-top: -5px}
b {font-family:"Verdana";font-weight:bold;color:black;margin-top: -5px}
H1 { font-family:"Verdana";font-weight:normal;font-size:18pt;color:red }
H2 { font-family:"Verdana";font-weight:normal;font-size:14pt;color:maroon }
pre {font-family:"Lucida Console";font-size: .9em}
.marker {font-weight: bold; color: black;text-decoration: none;}
.version {color: gray;}
.error {margin-bottom: 10px;}
.expandable { text-decoration:underline; font-weight:bold; color:navy; cursor:hand; }
Server Error in '/' Application.
Runtime Error 
Description: An application error occurred on the server. The current custom error settings for this application prevent the details of the application error from being viewed remotely (for security reasons). It could, however, be viewed by browsers running on the local server machine.
Details: To enable the details of this specific error message to be viewable on remote machines, please create a <customErrors> tag within a "web.config" configuration file located in the root directory of the current web application. This <customErrors> tag should then have its "mode" attribute set to "Off".
<!-- Web.Config Configuration File -->
<configuration>
<system.web>
<customErrors mode="Off"/>
</system.web>
</configuration>
Notes: The current error page you are seeing can be replaced by a custom error page by modifying the "defaultRedirect" attribute of the application's <customErrors> configuration tag to point to a custom error page URL.
<!-- Web.Config Configuration File -->
<configuration>
<system.web>
<customErrors mode="RemoteOnly" defaultRedirect="mycustompage.htm"/>
</system.web>
</configuration>

Someone who has a clue? What can it be?

1
  • I wonder if it could interfere with the "Administration menu-module"? I've tried to uninstall it, but no sucess... anyone? Commented Oct 23, 2012 at 11:49

1 Answer 1

2

This worked for me: https://drupal.org/node/1036202

Posted by Kye on February 11, 2013 at 11:45am I had the same problem today. Went through this and similar threads. We were hosting the site in IIS and the problem turned out to be URLScan, and colon in the URL plan. I had to do is exclude the colon rule and everything worked as expected.

C:\Windows\system32\inetsrv\urlscan\UrlScan.ini

; : ; Don't allow alternate stream access

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.