2

An RSS-feed on my site doesn't show up in the HTML <head> as it is supposed to, which makes it very difficult to find. Here's my situation:

  • A view is displaying the latest blog posts.
  • This view has two displays: a content pane and a feed. The feed is attached to the content pane.
  • The content pane is shown on a page using panels and page manager.

The RSS-icon shows up at the bottom of the view, so the feed is definitely there. However, the feed doesn't show up in the the meta-tags, so the browser doesn't discover the feed like it's supposed to. Does anyone know where this goes wrong, and how I can fix it?

EDIT

I managed to get this working, but I'm not sure exactly how. I updated Panels, Views and CTools to the latest stable versions, and attached the feed to the master display as well. After this, the feed was present in the head.

I hope this works for others as well. If anyone can give a better explanation to what was wrong and how to fix it, you're very welcome to leave it as an answer here.

0

I had a similar issue before. As you mentioned, feed auto-discovery works through the link in the tag (see http://diveintohtml5.info/semantics.html#rel-alternate for more info).

I found that some themes and modules add it in automatically, while others don't. If yours is absent, you can auto-discover the default drupal RSS feed by adding the following to a preprocess function:

$element = array(
  '#tag' => 'link', 
  '#attributes' => array( 
    'href' => '/rss.xml', 
    'rel' => 'alternate',
  ),
);
drupal_add_html_head($element, 'mymodule');

Alternatively, you could just add it into the html.tpl.php file, as mentioned in this post: http://www.webbykat.com/2012/03/adding-feedburner-rss-link-your-theme-drupal-7-omega

Regarding Views, I have found that enabling auto discovery means adding a "Feed" display then turning on the setting at Feed Settings > Attach To > Master, as you did. You can also set it to include other displays to get the RSS icon to display in those views.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.