1

I am getting this error

Notice: Undefined index: allowed_values_function in list_allowed_values() (line 239 of /var/www/html/drupal/modules/field/modules/list/list.module).
Notice: Undefined index: allowed_values in list_allowed_values() (line 248 of /var/www/html/drupal/modules/field/modules/list/list.module).
Notice: Undefined index: allowed_values_function in list_allowed_values() (line 239 of /var/www/html/drupal/modules/field/modules/list/list.module).
Notice: Undefined index: allowed_values in list_allowed_values() (line 248 of /var/www/html/drupal/modules/field/modules/list/list.module).

In my view I have added filters "a" and "b".

In content type "a" is list(text) with default value none. and "b" is also list(text) with default value none.

If default value is not none then I am not getting the notice.

I want the default value to be none for the fields.

What should be done so that these "Notice" do not appear.

2

I had the same problem. I had deleted a field which was being referenced in a view. I deleted the field from the View and it resolved the problem.

Also if you are still seeing the notice try clearing the Views cache at admin/structure/views/settings/advanced

3

This can happen if you delete a field from the definition of a custom content type and that field is still referenced by a View. Even if you added a new field with the same name as the one you deleted the problem will persist. You need to remove the old field from the View definition and then add the new field to the View.

  • I thought thats the problem intially. and deleted the whole view and created again. But its the same problem again.Any other reasons which you suggest? – Cindrella Nov 9 '12 at 7:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.