1

I've created a view which is displaying time tracking information. Everything works great except one thing and I can't figure out what the issue is. I have an exposed filter which filters by authorname. The filter by default is an autocomplete text field. When I am logged in as an admin role, the autocomplete works as it should, however when I am logged in as an authenticated user, that filter stops working. All my other exposed filters work, except this one. I am assuming it is a permissions issue, but I cannot for the life of me figure out what I need to enable to allow a regular user use this filter.

Any suggestions would be appreciated. I am using D7 with Views.

3
  • is Access: Permission | View published content in your Views Page settings Nov 1, 2012 at 16:17
  • it may be the "View user profiles" permission? Nov 1, 2012 at 16:33
  • The permission "view published content" and also "View user profiles" have been checked off. I realized after that the autocomplete is actually showing up, however, unlike the admin user, the autocomplete suggestion drop down shows up near the top of the page. So I wasn't seeing it because it was showing up off the page. It's weird. As an admin, this doesn't happen. Also I am using a standard Bartik theme with no modifications as I am in a testing state.
    – kaykills
    Nov 1, 2012 at 17:16

1 Answer 1

0

I just installed the Administration Views module and ran into this issue. Setting the "View user profiles" permission fixed the problem. Thanks @Marius Ilie.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.