I install Profile 2 module and create separate registration page. after login with this user not showing that fields on edit user page Can any one help me in this

  • What is your Drupal version? Can you see the fields as the administrator? Have you checked the user's permissions?
    – LLub
    Nov 2, 2012 at 13:31

4 Answers 4


Give the permission "[PROFILETYPE]Edit own profile" under "Profile2" section to the respective user roles.

And the fields will be appeared on edit user page.

  • this should happen automatically? I'm not getting any profile2 fields on my edit page and those permissions are set.. :/
    – Damon
    Jan 23, 2013 at 20:54
  • even i am having the exact same problem..however in my case the field which are marked as required are displaying but the rest fields are not
    – why
    Feb 8, 2013 at 17:09
  • I have the same issue,I want profile 2 fields to appear on the same with other account fields.How can I do that?
    – Dion
    Oct 9, 2013 at 20:18

@theBraveDave - THANK YOU THANK YOU THANK YOU!! - I don't have enough "points" to vote-up your answer, but that fixed my problem with profile2.


  1. If you're using Panels, check the admin/structure/pages admin page has the /user/%user/edit turned off
  2. When editing the profile type (from admin/structure/profiles), make sure "Provide a separate page for editing profiles" is turned off

Then suddenly it started working again. (I'd recently done a Drupal core update plus ctools plus other key modules and suddenly profile2 had stopped working. It appears that somehow the user/edit page was turned back on again and it was as simple as turning it back off ("simple" once I read @theBraveDave's post - thank you!)



Using profile2, the first 'main' profile you set up needs to have the box 'Provide a separate page for editing profiles' unchecked on the administration page before it will display on user/[id]/edit forms.

Admin form at /admin/structure/profiles

main profile example


I was having the problem where I would be on my user edit page and I could see my profile2 profile buttons on the top right. Clicking on them though would just load the same drupal core user/edit page. The profile link was highlighted like I was on that particular profile2 profile edit page, but only the standard core user edit form fields were showing.

I then remembered I was toying around with Drupal Panels and found that I had enabled the Drupal Panels Page- User edit template /user/%user/edit

I disabled this panel page and then when I clicked on my profile2 profile button from the standard Drupal core user/edit page my Profile2 profile loaded properly. Hope this helps someone.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.